Editar som surround com o Kdenlive

Até o momento da redação deste texto, o Kdenlive suporta apenas a renderização de um projeto em vídeo com áudio estéreo. Não é possível renderizar para mais canais de áudio ou mapear explicitamente faixas de áudio para canais no áudio renderizado. Para editar e criar som surround, algumas etapas manuais, incluindo o uso de ferramentas externas, são necessárias.

Este guia utiliza um sistema de som surround 5.1 de seis canais como exemplo.

Ferramentas externas utilizadas aqui

  • Audacity - Editor e gravador de áudio gratuito

  • avconv - Um conversor de vídeo e áudio

Nota

O Kdenlive usa o ffmpeg, enquanto no (k)ubuntu, o ffmpeg está obsoleto e o avconv é usado em seu lugar. Portanto, essas (e possivelmente outras) distribuições já têm o avconv instalado.

Criando um novo som surround

Este guia descreve uma possível solução alternativa usando o Audacity para criar e renderizar uma trilha de áudio surround 5.1 que pode ser adicionada ao vídeo renderizado pelo Kdenlive.

Nota

Recursos mais avançados, como panorâmica surround (ou seja, permitir que um som se mova da parte traseira para a frontal), estão além das capacidades do Audacity, mas é possível criar efeitos semelhantes manualmente.

Criar e editar som surround com o Audacity.

O exemplo a seguir, de um sistema de som surround 5.1 simples, é utilizado neste guia:

  • Algumas gravações de campo originais da frente (estéreo)

  • Alguma voz vinda do centro (frontal) (mono)

  • Música vinda da parte traseira (estéreo)

Se, como neste exemplo, for necessário usar uma gravação de campo original de um videoclipe para criar a trilha de áudio surround, ela pode ser facilmente extraída usando o Kdenlive com a opção Extrair áudio ‣ Wav 48000Hz no menu de contexto do clipe. Isso cria um arquivo de áudio WAV na mesma pasta onde o videoclipe está localizado.

Os trechos de áudio a serem usados ​​neste exemplo são:

  • Field.wav (estéreo) para Front L+R

  • Voice.wav (mono) para Centro

  • Music.mp3 (estéreo) para Surround L+R (traseiro)

Em um novo projeto do Audacity, eles podem ser importados na ordem acima com Menu ‣ Arquivo ‣ Importar ‣ Áudio…, o projeto deverá ficar parecido com isto:

../../_images/AudacitySurround.jpg

Captura de tela do Audacity

O mapeamento de canais para som surround 5.1 é o seguinte:

  • 1 - Frontal esquerdo

  • 2 - Frontal direito

  • 3 - Central

  • 4 - LFE

  • 5 - Surround esquerdo

  • 6 - Surround direito

Nota

O canal LFE (Efeitos de Baixa Frequência) é frequentemente chamado de “canal do subwoofer”, o que não é totalmente correto. Um sistema de som surround funciona perfeitamente sem um subwoofer. Nesse caso, o sistema de som surround redirecionará o canal LFE para as caixas acústicas “grandes”, geralmente as frontais.

A faixa estéreo “Campo” agora pode ser mapeada para Frontal L+R, “Voz” para Central e “Música” para Surround L+R. Há apenas um problema: as caixas de som surround (traseiras) de um sistema de som surround geralmente são “pequenas” e não conseguem reproduzir frequências baixas. Portanto, seria necessário mapear a faixa de baixa frequência da faixa “Música” para o canal LFE, caso contrário, a música pode soar um pouco “fraca”.

Para isso, basta duplicar a faixa “Música” selecionando-a em Menu ‣ Editar ‣ Duplicar e, em seguida, em Dividir estéreo em mono no menu de contexto da terceira faixa. Depois, uma das duas faixas mono pode ser excluída e a outra renomeada para “LFE”.

Agora, o efeito “Equalização…” pode ser usado para cortar frequências acima de aproximadamente 100Hz da faixa “LFE” e, inversamente, cortar frequências abaixo de aproximadamente 100Hz da faixa “Música”.

Nota

Criar um som surround tecnicamente perfeito é uma ciência à parte e, portanto, está além do escopo deste guia. Consulte os recursos relevantes na internet para obter mais detalhes.

Por enquanto, resta garantir que a trilha de som surround tenha a mesma duração que a trilha de vídeo à qual será adicionada. A trilha de vídeo usada neste exemplo tem 1 minuto de duração, portanto, as durações das trilhas de áudio no Audacity são ajustadas de acordo.

O projeto do Audacity agora deve ter uma aparência semelhante a esta:

../../_images/AudacitySurroundLFE.jpg

Captura de tela do projeto Audacity

O próximo passo é exportar o projeto para um arquivo de áudio multicanal com som surround 5.1. O formato utilizado aqui é o AC-3 (Dolby Digital).

Antes de exportar, o Audacity precisa ser configurado para permitir a exportação para um arquivo de áudio multicanal: Em Menu ‣ Editar ‣ Preferências, em Importar/Exportar, selecione “Usar mixagem personalizada (por exemplo, para exportar um arquivo multicanal 5.1)”.

O projeto agora pode ser exportado para um arquivo de áudio surround 5.1:

  • Selecione Menu ‣ Arquivo ‣ Exportar…

  • Forneça um nome para “Nome” e selecione “Arquivos AC3 (FFmpeg)”.

  • Clique em Opções… e escolha “512 kbps” como “Taxa de bits”.

A janela “Opções avançadas de mixagem” deve aparecer. O número de “Canais de saída” deve ser 6 e o ​​mapeamento de canais já deve estar correto.

../../_images/AdvancedMixingOptions2.jpg

Opções de mixagem do Audacity

O resultado da exportação deve ser um arquivo *.ac3 que pode ser reproduzido com, por exemplo, o VLC ou o Dragon Player.

Multiplexando vídeo e áudio simultaneamente

A etapa final consiste em adicionar a trilha de áudio surround à trilha de vídeo, supondo que o vídeo tenha sido renderizado sem áudio.

Nota

Ao combinar arquivos de áudio e vídeo em um único arquivo, os fluxos originais são simplesmente copiados, sem transcodificação. Portanto, não há perda de qualidade nos fluxos de áudio ou vídeo. Além disso, como os fluxos são apenas copiados, a combinação é muito rápida.

Supondo que a faixa de vídeo foi renderizada para o arquivo Video.mkv e o áudio surround foi exportado para o arquivo 5.1.ac3, o comando para multiplexar ambos em Video-5.1.mkv com o avconv seria:

avconv -i Video.mkv -i 5.1.ac3 -c copy -map 0:0 -map 1:0 Video-5.1.mkv

O resultado deverá ser um vídeo MKV contendo uma trilha de áudio Dolby Digital 5.1 surround.

Edição de som surround existente

Ao adicionar um clipe com mais de dois canais a um projeto, o Kdenlive cria uma miniatura de áudio que exibe corretamente todos os canais de áudio:

../../_images/AudioThumbnail.png

Linha do tempo do Kdenlive (Observação: versão antiga!)

O clipe pode ser editado e efeitos (de áudio) podem ser aplicados a ele, e tudo parece funcionar perfeitamente - mas, ao renderizar o projeto, verifica-se que a faixa de áudio no arquivo de vídeo resultante tem apenas 2 canais (estéreo).

Os passos a seguir fornecem uma solução alternativa manual para esse problema.

Extrair e dividir a faixa de áudio.

O primeiro passo é extrair a faixa de áudio do clipe de vídeo. Isso pode ser feito no Kdenlive com a opção Extrair áudio ‣ Wav 48000Hz no menu de contexto do clipe. Isso cria um arquivo de áudio WAV na mesma pasta onde o clipe de vídeo está localizado.

O arquivo de áudio WAV extraído pode então ser aberto no Audacity, onde deverá exibir todos os 6 canais, que são:

  • 1 - Frontal esquerdo

  • 2 - Frontal direito

  • 3 - Central

  • 4 - LFE

  • 5 - Surround esquerdo

  • 6 - Surround direito

Nota

O canal LFE (Efeitos de Baixa Frequência) é frequentemente chamado de “canal do subwoofer”, o que não é totalmente correto. Um sistema de som surround funciona perfeitamente sem um subwoofer. Nesse caso, o sistema de som surround redirecionará o canal LFE para as caixas acústicas “grandes”, geralmente as frontais.

A ideia agora é dividir o som surround em quatro arquivos de áudio separados (estéreo/mono) que o Kdenlive possa processar:

  • Frontal (estéreo)

  • Central (mono)

  • LFE (mono)

  • Surround (estéreo)

Primeiro, o Audacity precisa ser configurado para não exportar sempre para arquivos de áudio estéreo: Em Editar ‣ Preferências, em Importar/Exportar, selecione “Usar mixagem personalizada (por exemplo, para exportar um arquivo multicanal 5.1)”.

Agora, as faixas 1+2 e 5+6 devem ser transformadas em faixas estéreo selecionando Tornar faixa estéreo no menu de contexto da 1ª e da 5ª faixa, respectivamente. Isso deve resultar em 4 faixas, duas estéreo e duas mono.

Em seguida, as 4 faixas devem ser renomeadas para “Frontal”, “Central”, “LFE” e “Surround”, começando de cima, usando Nome… no menu de contexto de cada faixa.

As faixas agora estão assim:

../../_images/AudacityChannels2.jpg

Captura de tela do projeto Audacity

Depois de todo esse trabalho árduo, exportar as quatro faixas para quatro arquivos de áudio separados é fácil com Menu ‣ Arquivo ‣ Exportar ‣ Exportar vários…. Use “WAV” como “Formato de exportação”, o restante das configurações já deve estar correto: “Dividir arquivos com base em: Faixas” e “Nomear arquivos: Usando rótulo/nome da faixa”.

A caixa de diálogo “Editar metadados” pode aparecer para cada faixa. Basta clicar em OK. Ao final, deverá aparecer uma caixa de diálogo de confirmação e quatro arquivos de áudio deverão ter sido exportados: Front.wav, Center.wav, LFE.wav e Surround.wav.

Importar faixas de áudio para o Kdenlive

Os arquivos de áudio criados anteriormente agora podem ser adicionados ao projeto Kdenlive usando Menu ‣ Mídia ‣ Adicionar mídia ‣ Adicionar clipe.

Como um projeto contém apenas duas faixas de áudio por padrão, é necessário adicionar mais duas usando Menu ‣ Sequência ‣ Faixas ‣ Inserir faixa antes de adicionar as quatro faixas de áudio à linha do tempo.

O próximo passo é agrupar as quatro faixas de áudio com o clipe de vídeo, selecionando todas elas e, em seguida, escolhendo Menu ‣ Sequência ‣ Agrupar clipes.

Nota

Não se esqueça de silenciar a faixa de áudio original no videoclipe, se necessário!

O projeto Kdenlive agora deve estar pronto para a edição usual, como cortar clipes e adicionar efeitos, e deve ter uma aparência semelhante a esta:

../../_images/KdenliveProjectEdit.jpg

Exemplo de projeto Kdenlive (Observação: versão antiga!)

Renderizando o projeto

Como não é possível renderizar o projeto com uma faixa de áudio surround, algumas etapas manuais são necessárias para contornar esse problema.

Primeiro, a faixa de vídeo precisa ser renderizada sem áudio. Isso é feito simplesmente renderizando o projeto como de costume, mas sem áudio, desmarcando a caixa de seleção Áudio.

Em seguida, cada uma das quatro faixas de áudio surround Front.wav, Center.wav, LFE.wav e Surround.wav precisa ser renderizada em um arquivo de áudio separado. Para cada uma delas, faça o seguinte:

../../_images/kdenlive2308_render_audio.webp

Exportar apenas o áudio em faixas separadas

  • Silencie todas as outras faixas de áudio

  • Clique em media-record Renderizar…

  • Insira o nome do arquivo correspondente em Arquivo de saída

  • Selecione a predefinição Somente áudio

  • Selecione o perfil WAV

  • Certifique-se de que Áudio esteja marcado

  • Certifique-se de que a opção Arquivo separado para cada faixa de áudio não esteja marcada

  • Clique em Renderizar para arquivo

Nota

Infelizmente, as faixas mono Center.wav e LFE.wav são renderizadas como faixas estéreo, e parece não haver maneira de evitar isso. Mas isso pode ser resolvido posteriormente no Audacity.

Compor um arquivo de áudio com som surround

Agora, as faixas de áudio separadas, renderizadas pelo Kdenlive, precisam ser “mescladas” em um único arquivo de áudio multicanal com som surround 5.1. Isso é feito novamente no Audacity:

Importe os arquivos Front.wav, Center.wav, LFE.wav e Surround.wav (nesta ordem!) usando Arquivo ‣ Importar ‣ Áudio…

As faixas “Center” e “LFE” agora estão em estéreo, o que não é o desejado. Isso pode ser corrigido selecionando Dividir estéreo para mono no menu de contexto de cada faixa e excluindo uma das duas faixas mono resultantes.

Por fim, o projeto Audacity deverá ter quatro faixas:

  • Frontal (estéreo)

  • Central (mono)

  • LFE (mono)

  • Surround (estéreo)

O projeto agora pode ser exportado para um arquivo de áudio surround 5.1:

  • Selecione Arquivo ‣ Exportar…

  • Forneça um nome para “Nome” e selecione “Arquivos AC3 (FFmpeg)”.

  • Clique em Opções… e escolha 512 kbps como “Taxa de bits”

A caixa de diálogo Opções avançadas de mixagem deve ser exibida. O número de Canais de saída deve ser 6 e o ​​mapeamento de canais já deve estar correto:

../../_images/AdvancedMixingOptions.jpg

Opções avançadas de mixagem do Audacity

O resultado da exportação deve ser um arquivo *.ac3 que pode ser reproduzido com programas como o VLC ou o Dragon Player.

Multiplexando vídeo e áudio simultaneamente

Como o vídeo e o áudio foram renderizados separadamente, ambos precisam ser multiplexados em um único arquivo contendo os fluxos de vídeo e áudio.

Nota

Ao combinar arquivos de áudio e vídeo em um único arquivo, os fluxos originais são simplesmente copiados, sem transcodificação. Portanto, não há perda de qualidade nos fluxos de áudio ou vídeo. Além disso, como os fluxos são apenas copiados, a combinação é muito rápida.

Supondo que a faixa de vídeo foi renderizada para o arquivo Video.mkv e o áudio surround foi exportado para o arquivo 5.1.ac3, o comando para multiplexar ambos em Video-5.1.mkv com o avconv seria:

avconv -i Video.mkv -i 5.1.ac3 -c copy -map 0:0 -map 1:0 Video-5.1.mkv

O resultado deverá ser um vídeo MKV contendo uma trilha de áudio Dolby Digital 5.1 surround.